owncloud 4.0.2 auf all-inkl. Webspace mit SSL-Proxy

So, owncloud 4.0.2 ist draußen und ich habe die Version bei mir getestet.
Nach den Tweaks aus Version 3 und einer etwas abgewandelten Version vom SSL-Proxy Patch für Version 3 läuft die neue cloud ganz ok bei mir.

Was bei mir funktioniert

Für alle, die nicht an der bestehenden Version herum basteln wollen, stelle ich meine Version zum Download zur Verfügung.

DOWNLOAD ALL-INKL VERSION VON OWNCLOUD 4.0.2

geändert wurden dabei die Dateien.

  • .htaccess
  • /3rdparty/Sabre/HTTP/Request.php
  • /config/config.sample.php
  • /lib/base.php

57 Gedanken zu „owncloud 4.0.2 auf all-inkl. Webspace mit SSL-Proxy

  1. Hi,
    ich habe auch einen SSL-Proxy im Einsatz von meinem Provider ala domain.de/ssl-proxy/meineDomain. Zurzeit linkt er alle Adressen auf „domain.de/meineDomain“ doch fehlt der Zusatz „/ssl-proxy/“ dazwischen. Weißt du wie das geht? Ich bin da schon am verzweifeln.

    Danke und LG GL

    1. Hi,
      da bin ich etwas überfragt, da es eine andere Verzeichnisstruktur ist.
      Der Patch in meiner Version wird dort wohl nicht funktionieren.

      Aber du kannst es trotzdem mal probieren, indem du die Dateien
      /3rdparty/Sabre/HTTP/Request.php
      /config/config.sample.php
      /lib/base.php

      aus meiner Version nimmst und vor dem Upload noch in der Datei config.sample.php „ssl-account.com“ in „ssl-proxy“ änderst.

      Würde mich mal interessieren, wohin dann umgeleitet wird.

  2. Nach Installation der getachten Version spielt OC 4.0.2 nun super mit dem Android-Client CardDAV zusammen. Allerdings wird bei den Kontakten in der Webanwendung bei Zugang über den SSL-Proxy kein Bild mehr angezeigt. Ist das bei dir auch der Fall?

    Gruß
    Georg

    PS: auch ohne SSL-Proxy-Zugang hat die Kontakterfassung noch ziemlich Potenzial zur Verbesserung.

    1. Ein Kontaktbild habe ich auch nicht. Der Link in der ContatcsApp scheint anscheinend falsch zu sein.
      Welche App hast du auf Android laufen? Ich habe CardDAV Sync free probiert und irgendwie übernimmt die App die Telefonnummern nicht richtig.

      BTW..Vor ein paar Taqen habe ich die App FolderSync für mich entdeckt. Ein geiles Teil!

      1. Ich habe die Bezahlversion „CardDAV-Sync beta“ in Kombination mit dem „Contact Editor Pro“. Ein echt cooles Gespann und endlich liegen meine Kontakte nicht mehr bei Google. FolderSync sieht ziemlich spannend aus, das muß ich mal ausprobieren. Verwendest du dann WebDAV(s)?

      2. Cool, werde mich die Tage dann ein weiteres mal mit den Kontakten beschäftigen.
        Wie hast du die Google Kontakte in OC importiert. Über den Google Export per vcf, oder über den Import per gsync? Was wurde dabei alles nicht importiert?

        Ja, ich verwende FolderSync mit WebDAVs? Die Konfiguration war etwas frickelig, da man die URAL auf zwei Felder aufteilen muss.
        Server-Adresse = ssl-account.com, Startordner = mydomain.com/owncloud/remote.php/webdav/
        So funktioniert es bei mir. Die lite Version dürfte reichen, wenn man keine Filterlisten anlegen will.

  3. Die Kontakte habe ich mit viel Liebe und Handarbeit🙂 mittels „Contact Editor Pro“ von Google nach OC verschoben. Da gibt es bei der Bearbeitung eines Kontaktes die Optionen „Kontakt in anderes Konto kopieren“ und „Konto des Kontaktes ändern“. Da ich mein Nexus S noch nicht lange hatte und erst ca. 30 Kontakte erfasst waren, ging das recht schnell. Dabei wurden alle Daten übernommen.
    Beim Export von Google über die Weboberfläche habe ich es nicht geschaft, die Bilder zu exportieren.

    1. Hi Georg,
      Ich habe mir jetzt mal den Contact Editor Pro geladen, finde dort aber keine Option Kontakte in ein anderen Konto zu schieben. Wie läuft das genau ab? Stehe gerade doch etwas auf dem Schlauch

      1. Hallo,

        du kannst oben auf das Google-Logo tippen, dann wird ein Dialog mit den entsprechenden Möglichkeiten eingeblendet. Sobald ein Kontakt dann in OC liegt, ist dort kein Google-G mehr, sondern das CardDAV Icon (weil es ein CardDAV Konto ist).
        Ich hatte allerdings das „Problem“, dass trotz „Konto ändern“ der Eintrag nur in das neue Konto kopiert wurde und somit 2x existierte. Falls das so sein sollte, kannst du einfach den Google-Kontakt löschen.

      2. Danke, habe die Option jetzt gesehen. Ich werde später einfach die Google Kontakte komplett ausblenden und löschen, wenn der owncloud sync über eine längere Zeit funktioniert.

        Ach, wenn du die Kommentare immer mit der gleichen Email Adresser schreibst, muss ich die nicht erst freischalten😉

  4. Hey, danke für deinen Beitrag. Genau das habe ich gesucht🙂
    Hast du auch eine Idee, wie die Seite immer über https aufgerufen wird?
    Zur Zeit kann man ja http oder https aufrufen.

    1. Versuche mal eine 301 Umleitung in der .htaccess mit diesem Ausdruck
      RewriteRule domain.de/owncloud/ https://ssl-account.com/domain.de/owncloud/$1 [R=301,L]

      https://all-inkl.com/wichtig/anleitungen/skripte/sonstiges/weiterleitung-auf-eine-andere-domain/per-html-und-metarefresh_78.html

      Berichte dann bitte ob es bei dir funktioniert.

      Bei mir gibt das einen Fuckup im Backend. Eine andere Idee habe ich jetzt nicht. Es wird sicher auf über einen redirect in der .htaccess gehen.

  5. Hat jemand roundcube bei all-inkl zum Laufen gebracht? Das gab es früher scheinbar mal als Software-Installer direkt von all-inkl. Will ich es jetzt installieren bekomme ich allerdings die Fehlermeldung:

    Net_IDNA2: NOT OK(Failed to load Net/IDNA2.php; See http://pear.php.net/package/Net_IDNA2)

    Himura meinte zum OC3 Beitrag, dass roundcube wunderbar laufe.
    Ich hoffe mir kann jemand weiterhelfen🙂

    Auch ist mir gerade aufgefallen, dass es OC4.02 als Install Paket bei all-inkl mittlerweile gibt. Werde es die Tage mal ausprobieren, ob es auch per ssl funktioniert.

    Grüße
    Thomas

    1. Für alle, die es interessiert,es scheint auch zu klappen, wenn man eine IDNA Implementierung in PHP geschrieben nutzt. Ihr findet sie unter: http://phlymail.com/en/downloads/idna/ -einfach herunterladen, in /programm/include/ kopieren, dann in der /programm/include/rcube_shared.inc folgende Zeile gleich am Anfang einfügen: include ‚idna_convert.class.php‘; und dann 2 mal
      $idn = new Net_IDNA2();
      durch
      idn = new idna_convert();

      ersetzen – schon funkioniert es. Der Test am Anfang schlägt zwar immer noch fehl, aber den könnt ihr einfach überspringen mit indem ihr im Installerverzeichnis folgende Datei aufruft: index.php?_step=2

      Grüße
      Thomas

      1. Ich habe es getestet. Erstmal wird auf jeden Fall eine Datenbank angelegt (mySQL) und der Aufruf über den SSL-Proxy geht gar nicht.
        Also nehm ich doch lieber deine Version😉

      2. Die Aussage kann ich bestätigen, bei mir konnte ich auch keine Verbindung via SSL herstellen. Das ist schon schade, weil es praktisch damit unbrauchbar wird. Ich habe gerade die Änderungen von 4.0.2 zu 4.0.3 verglichen. Dabei sind in den offiziellen Paketen folgenden Dateien gleich geblieben:

        .htaccess
        /3rdparty/Sabre/HTTP/Request.php

        In der modifzierten all-inkl Version von /lib/base.php fehlt in Zeile 259 folgende Codezeile:

        OC_App::checkAppsRequirements();

        Grüße
        Thomas

      3. Interessant. Hier mal die modifizierte Version 4.0.3
        http://www.multiupload.nl/73QYROB3E5
        Dieser funktioniert bei mir nur mit einer kleinen Einschränkung zusammen mit dem SSL-Proxy. So wird nach der Eingabe der Logindaten wieder auf die Seite
        ssl-account/owncloud/ weitergeleitet. Mit dem „zurück“ Button vom Browser komme ich aber in die SSL-Cloud und dort funktionieren die internen Links auch. Was sich jetzt so groß geändert hat kann ich nicht sagen.

      4. Das mit der falschen Weiterleitung ist mir gestern nacht gar nicht aufgefallen, aber es ist schon relativ nervig.
        Momentan stürzt immer mein owncloud sync-client ab, ohne Fehlermeldung und ich finde auch kein aussagekräftiges log-file.
        Auch habe ich das roundcube Plugin nicht zufriedenstellend zum Laufen gebracht. Wobei die aktuelle Version von github deutlich weniger Fehler wirft, als die veröffentlichte. Das Hauptproblem ist auch hier wieder der ssl-proxy.

  6. Hallo,
    Habe soeben auch owncloud v4.02 mit dem software installer von all-inkl.com installiert auf meiner “subdomain.domain.com”.
    Ich müsste unbedingt deren ssl-proxy benutzen.
    Gibt’s eine „step-by step“ Anleitung für Nicht-Experten, wo genau (welche Dateien) wie welche Veränderungen vorgenommen warden müssen, damit alles glatt läuft?
    Danke!

    1. Hi, nimm die vier, oben im Artikel, angegebenen Dateien aus meiner Version und ersetzte damit die Version auf dem Server. Das sollte funktionieren. Vorher ein Backup der Serverdateien machen, damit du wieder zurück kannst.
      Eine Schritt für Schritt Anleitung gibt es auch im Netz, bin aber heute nur noch mit dem Handy online und habe den Link dazu nicht parat.

  7. Hat schon jemand positive Erfahrungen mit dem OwnCloud Client gemacht? Ich habe ihn auf 2 Rechnern installiert, auf einem schließt er sich nach gewisser Zeit von selbst. Auf dem zweiten kommt wenigstens eine Windows Fehlermeldung wie „OwnCloud funktioniert nicht mehr und muss geschlossen werden. Diese Erfahrung habe ich auch von jemand anderem gehört. Jedoch habe ich auf anhieb nichts weiter dazu gefunden.
    Läuft bei euch alles soweit problemfrei?

  8. Zitat „Hi, nimm die vier, oben im Artikel, angegebenen Dateien aus meiner Version und ersetzte damit die Version auf dem Server. Das sollte funktionieren“

    Vielen Dank.
    Wäre trotzdem dankbar, wo genau die „Veränderungen“ stecken. Es ist ja denkbar, das man in Zukunft diese Änderungen per Hand machen muß.

    Ich denke das ist für viele AllInkl Owncloud Nutzer hulfreich!!
    Danke,

  9. Es wird sicherlich von Version zu Version schwieriger, den SSL Proxy zu unterstützen… Eine Anfrage an die Mailinglist mit dem Verweis auf diesen Blog (anscheinend gibt es sehr großes Interesse und auch All-inkl bietet damit mit dem SSL Proxy eine schöne, weitgehend sichere Methode) könnte unter anderem Wunder bewirken… viele der Entwickler sind soweit mir bekannt der deutschen Sprache mächtig und können das hier lesen.😉

  10. Zitat Himura „Eine Anfrage an die Mailinglist mit dem Verweis auf diesen Blog (anscheinend gibt es sehr großes Interesse und auch All-inkl bietet damit mit dem SSL Proxy eine schöne, weitgehend sichere Methode) könnte unter anderem Wunder bewirken… “

    Wo sollen wir diese Anfrage starten? Ich kann das gerne machen. Wäre aber sinnvoll wenn SO VIELE ALS MÖGLICH diese Anfrage aktiv unterstützen!!!

  11. Hallo,
    also ich schaffe es nicht gemäss obigen Anleitungen den ssl-proxy zu benutzen.
    Kann mir jemand eine Step-by-step Anleitung in einem Komment schreiben, dem ich einfach folgen kann? – OC 4.02.

    Danke!

  12. Ich habe ein Update auf 4.0.4 gemacht. Im Endeffekt funktioniert alles soweit. Ich habe den config- und data-Ordner ausgelassen, die Änderungen in den geänderten Dateien (.htaccess, /3rdparty/Sabre/HTTP/Request.php, /config/config.sample.php, /lib/base.php) übernommen und das Ganze über die alte Installation (4.0.2) drüber gebügelt. Musste danach die Ordner-Rechte (apps, config, data) setzen, aber es hat auch danach funktioniert. NUR ich habe folgenden Bug jetzt:

    Wenn ich nun auf die Login-Seite gehe (https://ssl-account.com/mydomain.de/index.php) und meinen Benutzernamen und Password eingebe, werde ich auf den SSL-Proxy von All-Inkl weitergeleitet (https://ssl-account.com/index.php/) und bekomme eine 404-Not-Found.

    Wenn ich daraufhin die Login-Seite (https://ssl-account.com/mydomain.de/index.php) noch mal aufrufe, bin ich eingelogt und alles funktioniert.

    Irgendwo wird der Domain-Part beim Login aus der URL rausgeschnitten und die Weiterleitung erfolgt auf den SSL-Proxy. Hat irgendjemand eine Ahnung wo ich das im Code korrigieren muss?

    Bedanke mich im Voraus.

    1. Die 4.0.4 habe ich noch nicht ausprobiert. Hast du OC bei dir direkt im root Verzeichnis drin?
      Bei mir war ist es in der 4.0.3 auch so, dass ich nach dem login auf https://ssl-account.com/mydomain.de/owncloud/index.php weiter geleitet werde. Rufe ich erneut die Loginseite auf (zurück button im Browser), dann funktioniert auch alles.
      Die Änderung war bei dem Sprung von 4.0.2 auf 4.0.3. Wo das jetzt im Code steht weiß ich auch nicht. All zu sehr stört mich die Umstand jedoch nicht.
      Ich denke nur, dass es an der Zeit ist, dass die Entwickler dieses Feature direkt in OC implementieren. Denn es kann nicht sein, dass wir bei jeder neuen Version und Unterversion das Ding auf eine neue Art und Weise fixen müssen.

      Wenn du magst kannst du hier für uns voten http://bugs.owncloud.org/thebuggenie/owncloud/issues/oc-1161
      oder eine Mail an all-inkl mit Verweis auf diesen Artikel schicken.

  13. Bin nach Anleitung vorgegangen, aber bei folgendem Schritt:
    open 3rdparty/Sabre/HTTP/Request.php FIND:

    return $this->_SERVER[‚REQUEST_URI‘];

    Kann ich die gesuchte Zeile NICHT finden. OC 4.02.

    Letztendlich ist das alles auch ehh nur herumgeflicke… OC muss SSL-Proxy „nativ“ unterstützen, sonst wird jedes Update eine viel zu grosse Zeitinvestition, um jedesmal Änderungen händisch durchführen zu müssen…
    Ich und viele meiner Kollegen werden warten müssen.

  14. Hallo,
    die 4.04 habe ich mit etwas Mühe dank der Anleitungen hier zum laufen gebracht. Vielen Dank, Aber manche Dinge funktionieren über ssl-proxy nicht.

    Kurzum:
    1. Wie stehen die Chancen, daß diese paar zeilen Code durch die Entwickler eingepflegt werden? Kann man da etwas Druck machen? Mehr als einige Stunden Arbeit dürften es ja nicht sein, oder? Ansonsten bleibt OC für uns (und viele Andere) nicht verwendbar.
    2. Weiss jemand ob die OC Datei-Encryption inzwischen „sicher“ genug ist. Vor einiger Zeit hiess es ja noch, das Passwort würde im klartext auf dem Server gespeichert, und somit durch jeden Admin auslesbar sein…Wurde da nachgebessert`?

    1. Den Anstoß hast du doch schon gegeben, in deinem Feature Request auf bugs.owncloud.org
      Ich habe eine EMail an all-inkl geschrieben, dass die den Code einpflegen sollen bzw. sich mit den OC Entwicklern in Verbindung setzen sollen. Eine Antwort darauf habe ich bisher nicht erhalten.

      Zur Encryption kann ich dir nichts sagen.

      Abwarten was die 5.0 bringt.

      Bei mir läuft im Moment noch 4.0.2 und für Kontakt- Kalendersync und automatischen Upload vom Handy aus via „FolderSync“ ist die Version ausreichend. Mehr brauche ich im Moment nicht.

  15. Habe eben auch versucht ein paar Änderungen für die Version 4.0.4 einzupflegen. Damit man nach dem Login korrekt weitergeleitet wird muss die /lib/util.php wie folgt geändert werden (dies kann evtl. Nebenwirkungen unter bestimmten Umständen haben):

    /**
    * Redirect to the user default page
    */
    public static function redirectToDefaultPage(){
    OC_Log::write(‚core‘,’redirectToDefaultPage‘,OC_Log::DEBUG);
    if(isset($_REQUEST[‚redirect_url‘]) && /*ALL-INKL PATCH /* ( */substr($_REQUEST[‚redirect_url‘], 0, strlen(OC::$WEBROOT)) == OC::$WEBROOT /*ALL-INKL PATCH || $_REQUEST[‚redirect_url‘][0] == ‚/‘)*/) {
    header( ‚Location: ‚.$_REQUEST[‚redirect_url‘]);
    }
    else if (isset(OC::$REQUESTEDAPP) && !empty(OC::$REQUESTEDAPP)) {
    header( ‚Location: ‚.OC::$WEBROOT.’/?app=‘.OC::$REQUESTEDAPP );
    }
    else {
    header( ‚Location: ‚.OC::$WEBROOT.’/‘.OC_Appconfig::getValue(‚core‘, ‚defaultpage‘, ‚?app=files‘));
    }
    exit();
    }

    Damit die Links unter den pers. Einstellungen korrekt angezeigt werden muss die /lib/helper.php wie folgt geändert werden (Dadurch sollte auch das gsync plugin funktionieren):
    /**
    * @brief Returns the server protocol
    * @returns the server protocol
    *
    * Returns the server protocol. It respects reverse proxy servers and load balancers
    */
    public static function serverProtocol() {
    /*ALL-INKL PATCH – SSL Proxy does not set header correctly so we need to set https manually for ssl-account.com*/
    if ($_SERVER[‚HTTP_X_FORWARDED_HOST‘] == ’ssl-account.com‘){
    $proto = ‚https‘;
    }else{
    if (isset($_SERVER[‚HTTP_X_FORWARDED_PROTO‘])) {
    $proto = strtolower($_SERVER[‚HTTP_X_FORWARDED_PROTO‘]);
    }else{
    if(isset($_SERVER[‚HTTPS‘]) and !empty($_SERVER[‚HTTPS‘]) and ($_SERVER[‚HTTPS‘]!=’off‘)) {
    $proto = ‚https‘;
    }else{
    $proto = ‚http‘;
    }
    }
    }
    return($proto);
    }

    Wie immer ohne Gewähr. Viel Spaß.

    1. Kannst du evtl. noch die Änderungen in der helper.php checken.
      Ich bekomme da die Fehlermeldung
      Notice: Use of undefined constant account – assumed ‚account‘ in /www/…/lib/helper.php on line 100
      wenn ich deine Änderung übernehme.

      EDIT: Komischerweise tritt der Fehler nicht auf, wenn ich die Anführungszeichen ändere s.
      if ($_SERVER[‚HTTP_X_FORWARDED_HOST‘] == „ssl-account.com“){
      $proto = „https“;

      Die persönlichen Links sind dann trotzdem https.

      1. Geile Arbeit RedCid.

        Wenn es okay für dich ist, werde ich morgen eine gepatchte 4.0.4 zur Verfügung stellen, in der deine Änderungen auch drin sind.

      2. Klar kannst Du das machen. Ich hab bis jetzt nichts gefunden, was mit allen hier erwähnten Änderungen nicht funktioniert. Leider sind wir bei der nächsten Änderung von owncloud wieder bei 0.

        Ich hab ein Backup der aktuellen Änderungen gezogen, hoffen wir mal dass man mit einem Diff die Änderungen wieder schnell hinzufügen kann. IMHO gehört SSL-Proxy Support nativ in owncloud integriert. Wir sind nicht die einzigen, die dieses Setup haben. Ich bin mir aber auch nicht sicher wieviele Änderungen überflüssig wären, wenn ssl-account die Header korrekt setzen würde. Falls die Header korrekt wären, wäre die Anpassung der helper.php z.B. nicht notwendig gewesen.

  16. Ich habe das roundcube plugin in folgender Konfiguration laufen:
    * roundcube liegt nicht im owncloud verzeichnis
    * roundcube ist über den ssl-proxy unter einer eigenen Adresse erreichbar

    Die diffs der bearbeiteten Dateien sehen wie folgt aus (ich habe auch noch andere Fehler wg. Warnmeldungen korrigiert). Bitte beachten, dass diese Version nur mit der oben genannten Konfiguration funktioniert bzw. nur damit getestet wurde. Wie immer ohne Gewähr…

    HINWEIS: Als Verzeichnis muss „/subdomain.domain.tld/“ ohne Anführungszeichen gesetzt werden.

    RoundcubeLogin.class.php – Anpassungen für die Konfig + Warnmeldungen

    268c268
    if (isset($_COOKIE[‚roundcube_sessid‘]))
    271c271
    if (isset($_COOKIE[‚roundcube_sessauth‘]))
    322,324c322,331
    < $port = ($_SERVER['HTTPS']) ? 443 : 80;
    < $host = ($port == 443) ? "ssl://localhost" : "localhost";
    //$port = 443;
    > $port = (isset($_SERVER[‚HTTPS‘])) ? 443 : 80;
    > if(isset($_SERVER[‚HTTP_X_FORWARDED_HOST‘])){
    > $port = 443;
    > $host = „ssl://“ .$_SERVER[‚HTTP_X_FORWARDED_HOST‘];
    > $reqhost = $_SERVER[‚HTTP_X_FORWARDED_HOST‘];
    > }else{
    > $host = (($port == 443) ? „ssl://“ : „“).$_SERVER[‚HTTP_HOST‘];
    > $reqhost = $_SERVER[‚HTTP_HOST‘];
    > }
    333c340
    rcSessionID)

    > if (!isset($_COOKIE[‚roundcube_sessid‘]) && $this->rcSessionID)
    336c343
    rcSessionAuth)

    > if (!isset($_COOKIE[‚roundcube_sessauth‘]) && $this->rcSessionAuth)
    345c352
    . „Host: „.$reqhost.“\r\n“
    359c366
    . „Host: „.$reqhost.“\r\n“

    mail.php – Anzeigefehler korrigiert

    172c172
    //$(\’#roundcubeFrame\‘).contents().find(\’#mainscreen\‘).css(\’top\‘,\’15px\‘);

    userSettings.php – Warnmeldung bei Einstellungen beseitigt

    12c12
    /*foreach($params as $param){
    15c15
    }*/

      1. Für den Einsatz von RoundCube empfehle ich den Sync über einen Google Account in RC selbst (http://sourceforge.net/projects/roundcubegoogle/files/) und nochmal in owncloud, damit die Kontakte in beiden identisch sind.

        Wenn jemand bei dem Roundcube Plugin einen Fehler erhält liegt es daran, dass Google einen auffälligen Login-Vorgang vermutet. Dann muss evtl. das Passwort des Accounts geändert werden (der Hinweis erfolgt beim einloggen) und auf jeden Fall diese Anleitung befolgt werden http://support.google.com/mail/bin/answer.py?hl=de&answer=14257&p=client_login Danach sollte RC die Kontakte synchronisieren.

        Die Einstellungen des RC Plugins finden sich in den RC Einstellungen unter Adressbücher. Bei jeder Änderung IRGENDEINER Einstellung in diesem Bereich, muss das Passwort neu eingegeben werden, da es sonst gelöscht wird.

        Wie ich sehe gab es heute ein Update des roundcubelogin Plugins. *hmpf* Also hier nochmal das Diff zur Version v1.1 damit es mit dem SSL-Proxy läuft:
        http://pastebin.com/WdXUadtZ

      2. Hallo RedCid,

        danke für die Diffs. Das wird mir hoffentlich auch helfen Roundcube zuverlässig zum Laufen zu bringen. Kannst du uns noch kurz sagen, ob du Version 0.72 oder 0.8rc von Roundcube verwendet hast?

        Besten Dank!
        Thomas

      3. @Thomas
        Ich habe Version 0.8rc verwendet aber es sollte mit beiden Versionen funktionieren.

  17. Hallo Tom und RedCid,

    ganz großes Lob für die SSL-Proxy Anpassung für All-Inkl. Sogar der Support von All-Inkl hat mich auf diesen Artikel verwiesen, nachdem ich dort wegen des Proxys angefragt habe. Super Arbeit!

    Ich habe mal eine Frage: ich nutze auch RoundCube auf meinem Server. Wie sieht die Implementation in ownCloud aus? Ich habe ehrlich gesagt überhaupt keine Vorstellung. Warum RC „in“ ownCloud?

    Viele Grüße, (auch ein) Tom

    1. Hallo Tom,
      Ich verwende roundcube selber nicht. Du wie ich das aber verstanden habe geht es nur darum alles unter einem Login (owncloud) zu haben, denn es wird roundcube nur mehr oder weniger in Owncloud eingebettet.

      Aber dazu kann RedCid mehr zu sagen.

      Gruß

    2. Hallo Tom,

      Tom hat eigentlich schon alles gesagt. Die Integration von Roundcube in OwnCloud hat den Vorteil, dass nur ein Login in owncloud benötigt wird und damit der zusätzliche Login in Roundcube entfällt.

      Mit einem Plugin können die Kontakte von OwnCloud und Roundcube synchronisiert werden und müssen so nicht doppelt verwaltet werden (das ist natürlich ohne die Integration durch das OwnCloud plugin für Roundcube auch möglich).

  18. Hat jemand Owncloud 4 mit einem Iphone am laufen? Ich versuche gerade die richtige Konfiguration für Caldav und Webdav zu finden. Kriege es aber mit und auch ohne SSL nicht hin.

  19. Welches Paket hast du bei all-inkl? Bekomme eine Verbindung über webdav einfach nicht zum laufen. Benötige ich da das Premium Paket?

Schreibe einen Kommentar

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s